Issues Adding New Payment Methods
Incident Report for EZ-CARE2
Resolved
We've confirmed that the issues with adding new payments have been resolved. We apologize for any inconvenience this might have caused you and appreciate your patience as we resolved the issue.
Posted over 1 year ago. Mar 06, 2018 - 07:17 EST
Investigating
Our team is investigating an issue adding payment methods in EZ2. We'll keep you posted with any updates here.
Posted over 1 year ago. Mar 05, 2018 - 15:09 EST