Insta-Charge Issues
Incident Report for EZ-CARE2
Resolved
We've confirmed that the Insta-Charge issues have been resolved. We apologize for any inconvenience this might have caused you and appreciate your patience as we resolved the issue.
Posted over 1 year ago. Mar 05, 2018 - 12:28 EST
Investigating
We're currently investigating an issue regarding the Insta-Charge feature impacting both hosted and non-hosted systems. Our team is working hard to understand the issue, and we'll keep you posted you here as soon as we have an update. Thank you for your patience.
Posted over 1 year ago. Mar 05, 2018 - 10:31 EST