EZ- CARE2 Phone Support Unavailable
Incident Report for EZ-CARE2
Resolved
Great news! Power has been restored to the majority of the team, so we're back in action! Thanks for your patience as we dealt with outages at the office and at home.
Posted Jun 04, 2020 - 09:58 EDT
Update
Power has been restored at the office and as a result phone support is now available. We still have some staff that have not had power restored at their homes, so wait times may be longer than normal. We will keep you updated here. Thanks again for your patience!
Posted Jun 04, 2020 - 07:18 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 04, 2020 - 07:18 EDT
Identified
Earlier today, severe thunderstorms swept through our area. As a result our headquarters office as well as the homes of many of our staff lost power. Our office has now been without power for approximately 7 hours and our backup batteries for our phone system, which our team is able to access from their homes, are now depleted meaning that phone support will not be available. Our team is currently working to forward our phones per our business continuity plans.

If you are in need of our assistance, please reach us through email at support@softerware.com.
Posted Jun 03, 2020 - 19:02 EDT
This incident affected: EZ-CARE2 Client Area and EZ-CAMP2 Client Area.