Phone System Issue
Incident Report for EZ-CARE2
Resolved
This incident has been resolved.
Posted May 14, 2020 - 21:36 EDT
Update
We have received confirmation that our vendor has resolved the issue causing our phone outage. Thank you for your patience.
Posted May 14, 2020 - 21:35 EDT
Update
Our phone system vendor is working on a resolution to the system outage. We have confirmed that the outage has affected many businesses in our area. We will keep you updated on the status of the issue as we hear updates.
Posted May 14, 2020 - 14:13 EDT
Investigating
We are currently investigating an issue that is causing our phone system to be down. We are working with our phone system vendor to resolve the issue, and we will keep you updated on the progress. The best way to reach our support team at this time is through Chat Support.
Posted May 14, 2020 - 11:36 EDT
This incident affected: EZ-2 Web.