Mastercard Payment Issue
Incident Report for EZ-CARE2
Resolved
Mastercard has confirmed that the issue has been resolved. Some Mastercard transactions may have been denied early this morning. Thank you for your patience as we waited for a resolution to this issue.
Posted about 1 year ago. May 10, 2018 - 10:35 EDT
Investigating
We have received a report that the Mastercard network is having issues, and we have seen several Mastercard transactions fail. We will post any updates we receive here on the StatusPage.
Posted about 1 year ago. May 10, 2018 - 09:43 EDT
This incident affected: Payment Processing.