Some Customers Unable to Log Into Hosted Systems
Incident Report for EZ-CARE2
Resolved
We have confirmed that the login issue that affected some customers this morning has been resolved. We apologize for any inconvenience this might have caused you, and we appreciate your patience as our team resolved the issue.
Posted over 1 year ago. Mar 12, 2018 - 12:54 EDT
Monitoring
We have implemented a solution and believe the login issues that have affected some customers have been resolved. We'll continue to monitor the issue and will update you when we've confirmed the issue is completely resolved.
Posted over 1 year ago. Mar 12, 2018 - 11:24 EDT
Investigating
We're currently investigating an issue that is preventing some customers from being able to access their hosted EZ2 system. This is our top priority to resolve and we'll keep you updated on the status of our progress here. Thank you.
Posted over 1 year ago. Mar 12, 2018 - 09:01 EDT