Intermittent Payment Processing Errors for a Subset of Clients
Incident Report for EZ-CARE2
Resolved
Our processing partner confirmed that the issue has been resolved. Errors occurred between 10:43 AM to 10:55 AM EST and have not occurred since then.
Posted Jun 03, 2020 - 11:57 EDT
Monitoring
We received communication from one of our payment processing partners that some payments that were attempted around 10:45 AM EST today may have experienced an error. This seems to be the same issue that occurred yesterday. This will only affect a subset of clients, so you may not be affected by this issue. Our partner has confirmed that a fix has been implemented and errors are no longer occurring.

If you encounter an error regarding any payments that occurred earlier this afternoon, please contact our Payment Services team at 800-220-8611.
Posted Jun 03, 2020 - 11:26 EDT
This incident affected: Payment Processing.