Intermittent Phone Issues with EZ Support Line
Incident Report for EZ-CARE2
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 30, 2019 - 15:35 EDT
Monitoring
We've been working with our phone carrier who is now onsite and have made some adjustments to routing significantly decreasing the chance customers would receive a busy signal when calling into support.
Posted 2 months ago. Aug 13, 2019 - 17:17 EDT
Investigating
We are currently investigating an issue with our phone carrier where some clients calling the support line receive a busy signal. If you receive a busy signal, you reach our support team in chat by logging into the Client Area of our website www.ezcaresoftware.com. We are working with our phone carrier to resolve this issue and we appreciate your patience.
Posted 2 months ago. Aug 13, 2019 - 12:27 EDT