Maintenance - 10/17
Incident Report for EZ-CARE2
Resolved
Maintenance has been completed
Posted Oct 19, 2021 - 06:51 EDT
Investigating
Our team will be performing server maintenance on 10/17. Hosted clients may experience connectivity issues while maintenance is being performed.
Posted Oct 15, 2021 - 14:29 EDT
This incident affected: EZ-2 Web.